[personal profile] fremen9
Wow, I'm just having a hellish day..actually it started yesterday but hasn't really ended today.
Basically I have two XP systems. One is my older XP install running inside a Vmware VM, and the other is a new XP installation running as the host OS.
I have a large GUI project written in VB6 that uses several 3rd party controls.
The problem is, if I compile the project (same source) on the VM XP machine, then that executable will run fine on both systems.
But if I compile the project on the host OS, then the executable will only run on the host computer, and on the VM machine it simply starts and disappears. No errors, no logs, nothing!

Sometimes I really hate VB6. If it can't find something or there's a problem, why can't it throw up a dialog or something to give me a clue.
I've tried comparing dependencies etc...but haven't found any differences yet.

Would be nice if there was a way to find out why an app just won't start.

Date: 2010-10-21 08:31 pm (UTC)
From: [personal profile] heather_dev
(this is [personal profile] delladea btw - I decided to have a separate account for dev-related entries)

That is indeed freaky.

Have you tried throwing in some MsgBox statements right when the application starts to see where it might be blowing up? Are you using the same set of install discs on each XP installation? Did you ever download KB fixes and updates for VB6 on one machine?

Can't be a corrupt library (I think) since the app will work when you compile on the other machine. Hmmm...

Profile

fremen9

October 2010

S M T W T F S
     12
3456789
101112 13141516
17181920212223
24252627282930
31      

Page Summary

Style Credit

Expand Cut Tags

No cut tags
Page generated Jul. 20th, 2017 02:25 pm
Powered by Dreamwidth Studios